CVE-2023-37481
Fides is an open-source privacy engineering platform for managing data privacy requests and privacy regulations. The Fides webserver is vulnerable to a type of Denial of Service (DoS) attack. Attackers can exploit this vulnerability to upload zip files containing malicious SVG bombs (similar to a billion laughs attack), causing resource exhaustion in Admin UI browser tabs and creating a persistent denial of service of the 'new connector' page (`datastore-connection/new`). This vulnerability affects Fides versions `2.11.0` through `2.15.1`. Exploitation is limited to users with elevated privileges with the `CONNECTOR_TEMPLATE_REGISTER` scope, which includes root users and users with the owner role. The vulnerability has been patched in Fides version `2.16.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. There is no known workaround to remediate this vulnerability without upgrading.
- Score
- CVSS 3.1 4.9 Medium
- Status
- Modified - security-advisories@github.com
- Published
- 2023-07-18
- Last modified
- 2024-10-18
- Weaknesses
- CWE-400
Affected products
References
- https://github.com/ethyca/fides/commit/8beaace082b325e693dc7682029a3cb7e6c2b69d
- https://github.com/ethyca/fides/security/advisories/GHSA-3rw2-wfc8-wmj5