CVE-2023-33246

For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution.  Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content.  To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .

Score
CVSS 3.1 9.8 Critical
Status
Analyzed - security@apache.org
Published
2023-05-24
Last modified
2025-10-21
Known exploited (CISA KEV)
since 2023-09-06, action due 2023-09-27: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Weaknesses
CWE-94

Affected products

References