CVE-2023-30631
Improper Input Validation vulnerability in Apache Software Foundation Apache Traffic Server. The configuration option proxy.config.http.push_method_enabled didn't function. However, by default the PUSH method is blocked in the ip_allow configuration file.This issue affects Apache Traffic Server: from 8.0.0 through 9.2.0. 8.x users should upgrade to 8.1.7 or later versions 9.x users should upgrade to 9.2.1 or later versions
- Score
- CVSS 3.1 7.5 High
- Status
- Modified - security@apache.org
- Published
- 2023-06-14
- Last modified
- 2025-02-13
- Weaknesses
- CWE-20
Affected products
- Traffic Server (Apache)
- Apache Traffic Server (Apache Software Foundation)
- Debian Linux (Debian)
- Fedora (Fedoraproject)
References
- https://lists.apache.org/thread/tns2b4khyyncgs5v5p9y35pobg9z2bvs
- https://lists.debian.org/debian-lts-announce/2023/06/msg00037.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/6GDCBNFDDW6ULW7CACJCPENI…
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FGWXNAEEVRUZ5JG4EJAIIFC3…
- https://www.debian.org/security/2023/dsa-5435