CVE-2023-29216

In Apache Linkis <=1.3.1, because the parameters are not effectively filtered, the attacker uses the MySQL data source and malicious parameters to configure a new data source to trigger a deserialization vulnerability, eventually leading to remote code execution. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.2.

Score
CVSS 3.1 9.8 Critical
Status
Modified - security@apache.org
Published
2023-04-10
Last modified
2025-02-13
Weaknesses
CWE-502

Affected products

References