CVE-2023-2279
The WP Directory Kit plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.2.1. This is due to missing or incorrect nonce validation on the 'admin_page_display' function. This makes it possible for unauthenticated attackers to delete or change plugin settings, import demo data, modify or delete Directory Kit related posts and terms via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Partial patches were made avilable in versions 1.2.0 and 1.2.1 but the issue was not fully patched until 1.2.2
- Score
- CVSS 3.1 5.4 Medium
- Status
- Modified - security@wordfence.com
- Published
- 2023-08-31
- Last modified
- 2026-04-08
- Weaknesses
- CWE-352
Affected products
References
- https://plugins.trac.wordpress.org/browser/wpdirectorykit/tags/1.1.8/admin/class-wpdirectorykit-admin.php#L170
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=2905795%40wpdirectorykit%2Ftrunk&old=2…
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8a7a6da3-d67c-42b3-8826-7e7fc9b938b4?source=cve