CVE-2022-44729
Server-Side Request Forgery (SSRF) vulnerability in Apache Software Foundation Apache XML Graphics Batik.This issue affects Apache XML Graphics Batik: 1.16. On version 1.16, a malicious SVG could trigger loading external resources by default, causing resource consumption or in some cases even information disclosure. Users are recommended to upgrade to version 1.17 or later.
- Score
- CVSS 3.1 7.1 High
- Status
- Modified - security@apache.org
- Published
- 2023-08-22
- Last modified
- 2026-10-08
- Weaknesses
- CWE-918
Affected products
- Xml Graphics Batik (Apache)
- Apache Xml Graphics Batik (Apache Software Foundation)
- Debian Linux (Debian)
References
- https://xmlgraphics.apache.org/security.html
- https://lists.apache.org/thread/hco2nw1typoorz33qzs0fcdx0ws6d6j2
- http://www.openwall.com/lists/oss-security/2023/08/22/2
- http://www.openwall.com/lists/oss-security/2023/08/22/4
- https://lists.debian.org/debian-lts-announce/2023/10/msg00021.html
- https://security.gentoo.org/glsa/202401-11