CVE-2022-44645
In Apache Linkis <=1.3.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures new datasource with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users to upgrade the version of Linkis to version 1.3.1.
- Score
- CVSS 3.1 8.8 High
- Status
- Modified - security@apache.org
- Published
- 2023-01-31
- Last modified
- 2025-03-27
- Weaknesses
- CWE-502
Affected products
References
- https://lists.apache.org/thread/zlcfmvt65blqc4n6fxypg6f0ns8fqfz4