CVE-2022-39944
In Apache Linkis <=1.2.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures a JDBC EC with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.2.0 will be affected, We recommend users to update to 1.3.0.
- Score
- CVSS 3.1 8.8 High
- Status
- Modified - security@apache.org
- Published
- 2022-10-26
- Last modified
- 2025-05-07
- Weaknesses
- CWE-502
Affected products
References
- https://lists.apache.org/thread/rxytj48q17304snonjtyt5lnlw64gccc