CVE-2022-39280

dparse is a parser for Python dependency files. dparse in versions before 0.5.2 contain a regular expression that is vulnerable to a Regular Expression Denial of Service. All the users parsing index server URLs with dparse are impacted by this vulnerability. A patch has been applied in version `0.5.2`, all the users are advised to upgrade to `0.5.2` as soon as possible. Users unable to upgrade should avoid passing index server URLs in the source file to be parsed.

Score
CVSS 3.1 7.5 High
Status
Modified - security-advisories@github.com
Published
2022-10-06
Last modified
2025-04-23
Weaknesses
CWE-1333, CWE-400

Affected products

References