CVE-2022-36125
It is possible to crash (panic) an application by providing a corrupted data to be read. This issue affects Rust applications using Apache Avro Rust SDK prior to 0.14.0 (previously known as avro-rs). Users should update to apache-avro version 0.14.0 which addresses this issue.
- Score
- CVSS 3.1 7.5 High
- Status
- Modified - security@apache.org
- Published
- 2022-08-09
- Last modified
- 2026-03-06
- Weaknesses
- CWE-190, CWE-20
Affected products
References
- https://lists.apache.org/thread/t1r5xz0pvhm4tosqopjpj6dz8zlsht07