CVE-2022-0757
Rapid7 Nexpose versions 6.6.93 and earlier are susceptible to an SQL Injection vulnerability, whereby valid search operators are not defined. This lack of validation can allow a logged-in, authenticated attacker to manipulate the "ANY" and "OR" operators in the SearchCriteria and inject SQL code. This issue was fixed in Rapid7 Nexpose version 6.6.129.
- Score
- CVSS 3.1 8.8 High
- Status
- Modified - cve@rapid7.com
- Published
- 2022-03-17
- Last modified
- 2024-09-16
- Weaknesses
- CWE-89
Affected products
References
- https://docs.rapid7.com/release-notes/nexpose/20220302/