CVE-2021-40331
An Incorrect Permission Assignment for Critical Resource vulnerability was found in the Apache Ranger Hive Plugin. Any user with SELECT privilege on a database can alter the ownership of the table in Hive when Apache Ranger Hive Plugin is enabled This issue affects Apache Ranger Hive Plugin: from 2.0.0 through 2.3.0. Users are recommended to upgrade to version 2.4.0 or later.
- Score
- CVSS 3.1 8.1 High
- Status
- Modified - security@apache.org
- Published
- 2023-05-05
- Last modified
- 2024-10-11
- Weaknesses
- CWE-732
Affected products
References
- https://lists.apache.org/thread/s68yls6cnkdmzn1k4hqt50vs6wjvt2rn