CVE-2021-37404
There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
- Score
- CVSS 3.1 9.8 Critical
- Status
- Modified - security@apache.org
- Published
- 2022-06-13
- Last modified
- 2024-08-04
- Weaknesses
- CWE-787
Affected products
References
- https://lists.apache.org/thread/2h56ztcj3ojc66qzf1nno88vjw9vd4wo
- https://security.netapp.com/advisory/ntap-20220715-0007/