CVE-2019-0226

Apache Karaf Config service provides a install method (via service or MBean) that could be used to travel in any directory and overwrite existing file. The vulnerability is low if the Karaf process user has limited permission on the filesystem. Any Apache Karaf version before 4.2.5 is impacted. User should upgrade to Apache Karaf 4.2.5 or later.

Score
CVSS 3.0 4.9 Medium
Status
Modified - security@apache.org
Published
2019-05-09
Last modified
2024-08-04
Weaknesses
CWE-22

Affected products

References