CVE-2018-25031
Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions. Note: This was originally claimed to be resolved in 4.1.3. However, third parties have indicated this is not resolved in 4.1.3 and even occurs in that version and possibly others.
- Score
- CVSS 3.1 4.3 Medium
- Status
- Modified - cve@mitre.org
- Published
- 2022-03-11
- Last modified
- 2024-08-05
- Weaknesses
- CWE-20, CWE-918, CWE-922
Affected products
References
- https://github.com/swagger-api/swagger-ui/issues/4872
- https://github.com/swagger-api/swagger-ui/releases/tag/v4.1.3
- https://security.netapp.com/advisory/ntap-20220407-0004/
- https://security.snyk.io/vuln/SNYK-JS-SWAGGERUI-2314885