CVE-2018-11778
UnixAuthenticationService in Apache Ranger 1.2.0 was updated to correctly handle user input to avoid Stack-based buffer overflow. Versions prior to 1.2.0 should be upgraded to 1.2.0
- Score
- CVSS 3.0 8.8 High
- Status
- Modified - security@apache.org
- Published
- 2018-10-05
- Last modified
- 2024-09-17
- Weaknesses
- CWE-787
Affected products
References
- https://cwiki.apache.org/confluence/display/RANGER/Vulnerabilities+found+in+Ranger
- https://lists.apache.org/thread.html/r04bc435a92911de4b52d2b98f169bd7cf2e8bbeb53b03788df8f932c%40%3Cdev.ranger.apache.o…
- https://lists.apache.org/thread.html/rd88077a781ef38f7687c100f93992f4dda8aa101925050c4af470998%40%3Cdev.ranger.apache.o…
- https://seclists.org/oss-sec/2018/q4/11