CVE-2018-1000301

curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of service that can result in curl can be tricked into reading data beyond the end of a heap based buffer used to store downloaded RTSP content.. This vulnerability appears to have been fixed in curl < 7.20.0 and curl >= 7.60.0.

Score
CVSS 3.1 9.1 Critical
Status
Modified - cve@mitre.org
Published
2018-05-24
Last modified
2026-04-15
Weaknesses
CWE-125

Affected products

References