CVE-2018-1000168

nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.

Score
CVSS 3.1 7.5 High
Status
Modified - cve@mitre.org
Published
2018-05-08
Last modified
2025-06-09
Weaknesses
CWE-20, CWE-476

Affected products

References