CVE-2018-1000165
LightSAML version prior to 1.3.5 contains a Incorrect Access Control vulnerability in signature validation in readers in src/LightSaml/Model/XmlDSig/ that can result in impersonation of any user from Identity Provider. This vulnerability appears to have been fixed in 1.3.5 and later.
- Score
- CVSS 3.0 7.5 High
- Status
- Modified - cve@mitre.org
- Published
- 2018-04-18
- Last modified
- 2024-08-05
- Weaknesses
- CWE-732
Affected products
References
- https://github.com/lightSAML/lightSAML/commit/47cef07bb09779df15620799f3763d1b8d32307a
- https://github.com/lightSAML/lightSAML/releases/tag/1.3.5