CVE-2017-1000376

libffi requests an executable stack allowing attackers to more easily trigger arbitrary code execution by overwriting the stack. Please note that libffi is used by a number of other libraries. It was previously stated that this affects libffi version 3.2.1 but this appears to be incorrect. libffi prior to version 3.1 on 32 bit x86 systems was vulnerable, and upstream is believed to have fixed this issue in version 3.1.

Score
CVSS 3.1 7.0 High
Status
Modified - cve@mitre.org
Published
2017-06-19
Last modified
2024-08-05
Weaknesses
CWE-119

Affected products

References